Ошибка 80240037 windows 8 1 как исправить

Microsoft продолжает усиленно радовать, удивлять и шокировать своих пользователей. Буквально на днях ко мне обратился коллега с такой проблемой: он приобрел и собрал новый ПК на базе нового процессора Intel Core i3 7100. На собранный компьютер был успешно установлен образ Windows 7. Но через некоторое время, после того, как Windows 7 закачала и установила все обновления через Windows Update, система перестала получать новые обновления со следующей ошибкой:

Unsupported hardware Your PC uses a processor that is designed for the latest version of Windows

Не поддерживаемое оборудование

При попытке выполнить поиск обновления через Windows Update появляется ошибка:

80240037 Windows Update encountered an unknown error

Неподдерживаемые процессоры для Windows 7 и Windows 8.1

Ограничения распространяется на следующие поколения процессоров:

В апреле 2017 года MSFT выпустило специальные патчи для предыдущих версий ОС

В описании патчей заявляется о появление функционала определения поколения процессора и поддерживаемого оборудования при поиске обновлений через Windows Update.

Соответственно, после установки данных обновлений, система начинает блокировать загрузку новых обновлений (в т.ч для MS Office) и драйверов на старых версиях ОС с ошибкой 80240037, тем самым вынуждая пользователей переходить на Windows 10 /Windows Server 2016. Таким образом, все старые системы с новым оборудованием перестают получать обновления безопасности и переходят в разряд уязвимых. Похоже на шантаж…

Кроме того, блокируется установка драйверов для видеоадаптеров на базе графических процессоров Intel седьмого поколения (Intel HD Graphics 610 — 650). В Windows 7 SP1 он определяется как стандартный VGA графический адаптер.

intel-video-driver-instaler

Как вы видите, непосредственно в установщике драйвера указано, что на оборудовании с седьмым поколением процессоров Intel, драйвер может быть установлен только в Windows 10×64.

Wufuc — патч для восстановления Windows Update

Пользователь GitHub под ником Zeffy выпустил небольшой патч Wufuc (windows update …. ну вы поняли), который позволяет избавиться от проблемы «несовместимого оборудования». Патч отключает сообщение Центра обновлений о несовместимости оборудовании и разрешает компьютеру получать обновления с Windows Update. Последнюю стабильную версию патча Wufuc можно скачать тут: https://github.com/zeffy/wufuc/releases/latest.

Есть версия Wufuc как для x86, так и для x64 систем.

Теперь фактическая замена файла wuaueng.dll не производится. Установщик wufuc_setup_x64.msi регистрирует новое задание планировщика, которое запускает wufuc при загрузке компьютера. Затем wufuc внедряет себя в процесс service host или службу wuauserv и перехватывает вызов функций IsDeviceServiceable и IsCPUSupported, модифицируя возвращаемый ответ.

Таким образом патч wufuc отключает сообщение «Оборудование не поддерживается» в Windows Update, и позволяет продолжать устанавливать обновления на системах Windows 7 и 8.1.

Понравилась статья? Поделиться с друзьями:
ErrorWin
Добавить комментарий

;-) :| :x :twisted: :smile: :shock: :sad: :roll: :razz: :oops: :o :mrgreen: :lol: :idea: :grin: :evil: :cry: :cool: :arrow: :???: :?: :!: